Cloud POS - Back Office

Incident

Cloud POS - Back Office

Status: closed
Start:
End:
Duration: 2 days 2 hours 16 minutes
Affected Components:
Cloud POS
Update

´╗┐Overnight Microsoft Azure experienced a power issue that impacted a subset of resources in the primary region housing the Cloud POS databases.  To remediate the issue, Transact Engineers failed over the Cloud POS database services to an alternate region.  All services are functioning properly in this configuration, however users may encounter minor latency when loading WebOffice pages.  This is a temporary measure and we will be returning the database to the primary region once the Microsoft Azure issues are fully resolved and verified.   Transact Engineers will be closely monitoring the system to ensure there are no additional impacts.

Monitoring

´╗┐Microsoft has resolved the underlying issue impacting some database services in our primary region, and Transact Engineers have determined that it is now safe to fail services back to their normal location. 

We will be performing that failback action at 4:00 AM EDT tomorrow morning, Monday September 18.  At that time parts of the system may be unavailable for up to one hour, but registers will continue to operate in offline mode.  All services are expected to be operating normally by 5:00 AM EDT tomorrow morning.

Please also note that Remote Control services will be unavailable until after that action has been completed.

Monitoring

´╗┐We have completed the database failback for Cloud POS.  At this time the system is operating normally.  Transact Engineers are monitoring the systems to ensure there are no further issues.

Resolved

Monitoring has confirmed that all systems are now operating normally.